Cisco 877 as ADSL modem

Network

Mostly as a reminder to myself, here’s how to set up a Cisco 877 as a “dumb” ADSL modem in PPPoE bridging mode.

The above is very simple to do, but if you only do that you lose the ability to access (via telnet or SSH) your Cisco over the network. That’s not nice, as serial cables are for emergency use only and you don’t want to fire up the terminal emulator just to check your sync speed. So here I’ve used IOS’ integrated routing and bridging mode, or short IRB.

!!! Cisco 877 as ADSL PPPoA to PPPoE bridge (with management IP)
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname modem
ip domain name sdfjkl.org
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 informational
enable secret 5 NotMyPassword
!
aaa new-model
aaa authentication login local_auth local
username admin privilege 15 secret 5 NotMyPasswordEither
!
!
dot11 syslog
no ip cef
!
!
! 
!
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
!! enable integrated bridging and routing mode to permit management IP whilst bridging PPP
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5snap
 !
 dsl operating-mode auto 
 bridge-group 1
!
!
interface Vlan1
 no ip address
 bridge-group 1
!
!! The bridge virtual interface gets the management IP
interface BVI1
	 ip address 192.168.2.1 255.255.255.0
!
ip default-gateway 192.168.2.2
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!         
control-plane
!
!! essential for BVI to work
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login authentication login_local
!
scheduler max-task-time 5000
end

The key components are in bold above. The bridge irb statement enables IRB mode, then the two bridge-group 1 lines link ATM0 (DSL) and Vlan1 into a bridge. This automatically creates a bridge group virtual interface named BVI1 on which we can then configure the management IP. That’s pretty much it. You will now get PPPoE frames on the same VLAN on which the Cisco listens for its management IP.